Building Bootstrap npm Installation

Solution

sudo apt-get install npm
sudo npm install recess connect uglify-js@1 jshint -g

Remember it is really important to install the first version of uglify-js which is uglify-js@1.

With the current version of npm in the Ubuntu repo, you will get error when trying to install uglify-js. If you try to add additional source and install the advanced version of npm, you will install uglify-js successfully. But you will not be able to uglify the bootstrap JavaScript files as they require the 1st version!

The Error

And this was the according error I got.

##################################################
Building Bootstrap...
##################################################

Running JSHint on javascript...             ✓ Done
Compiling LESS with Recess...               ✓ Done
Compiling documentation...                  ✓ Done
Binary
Error parsing arguments in: docs/assets/js/bootstrap.js
make: *** [build] Error 1

Off the topic, the way to correctly install rmagick:

sudo apt-get install libmagickwand-dev
sudo gem install rmagick

System Info

Distributor ID: Ubuntu
Description:    Ubuntu 12.04.2 LTS
Release:        12.04
Codename:       precise

View Comments

comments powered by Disqus